Probleme beim Einrichten vom Tracker auf Raspberry Pi

  • Hallo zusammen,





    ich habe versucht, den Tracker auf dem Raspberry Pi einzurichten. Aber als ziemlicher Linux-Neuling hat das erst mal nicht geklappt.


    Was habe ich gemacht?
    1. Wheezy runtergeladen, installiert, funktioniert.
    2. Tracker von Andreas Würl runtergeladen und entpackt.
    3. Wie im "readme" beschrieben alle nötigen Pakete mit apt-get gezogen.
    4. Doch beim Ausführen von make -f Makefile.cvs treten Fehler auf:
    /bin/sh: 2: aclocal: not found
    /bin/sh: 3: autoheader: not found
    ...
    ...
    make: *** [all] Error 1


    Habe ich bis dahin alles richtig gemacht? Warum treten beim make diese Fehler auf?


    Danke, Gruß
    Max

  • Hallo Max,


    aclocal ist im Paket automake enthalten; vielleicht gab es da ein Problem bei der Installation.


    Ich hab mal ein Binärpaket der aktuellen Version für den RaspberryPi gebaut. Es ist hier zu finden:


    Einfach herunterladen und als root-User mit
    > dpkg -i blitzortung-tracker_1.0.7_armhf.deb
    installieren. Falls noch nicht alle benötigten Pakete installiert sind, einfach
    > apt-get -f install
    starten.


    Die Konfiguration des Trackers lässt sich dann in der Textdatei
    /etc/default/blitzortung-tracker
    einstellen.


    Der Tracker selbst kann als Root-User mit
    > service blitzortung-tracker start
    oder
    > service blitzortung-tracker stop
    gestartet oder gestoppt werden.


    Über den cronjob
    /etc/cron.d/blitzortung-tracker
    wird der Tracker jede Minute neu gestartet, falls er nicht läuft.


    Wenn der Tracker läuft kannst Du mit
    > bo-tracker-status
    alle aktuellen Parameter anzeigen lassen.


    Viel Erfolg beim Installieren!


    Beste Grüße
    Andreas

    Edited once, last by westside ().

  • Ich habe meine Anlage wieder in Betrieb genommen nach baulichen Veränderungen im Haus, beim Start meines Linux Clients kommt folgende Meldung:


    30.06.2013 12:31:46.000 NOTICE : startup /usr/bin/bo-tracker -g sirf -b 38400 -d /dev/usb-bo -h rechenserver.de -u WaltherT -p meinPW --logfile=/var/log/blitzortung-tracker.log
    30.06.2013 12:31:54.035 NOTICE hardware.comm.Serial : checkLine() invalid line '1,300613,5041.0045,N,01301.2030,E,462.8,08,29e*71^M'
    Ist das so ok?


    Status sagt:
    heimserver:/dev# bo-tracker-status
    hardware
    firmware: 29e
    comm
    baudRate: 38400
    interfaceName: /dev/usb-bo
    gps
    status: A
    baudRate: 38400
    longitudeError: 5e-06
    altitude: 471
    altitudeError: 0
    longitude: 13.019992
    latitudeError: 3e-06
    date: 2013-06-30
    satelliteCount: 8
    time: 10:41:41
    latitude: 50.683443
    type: SiRF
    tickError: 0.0
    ticksPerSecond: 2457841.44
    process
    numberOfEvents: 1
    uptime: 00:09:48
    eventsPerSecond: 0.001701
    numberOfSeconds: 588
    command: getInfo
    software
    version: debT 1.0.6



    Grüße
    Thomas

  • Hallo Raspberry Pi User & Andreas


    Zitat;
    Ich hab mal ein Binärpaket der aktuellen Version für den RaspberryPi gebaut. Es ist hier zu finden:


    Einfach herunterladen und als root-User mit
    > dpkg -i blitzortung-tracker_1.0.7_armhf.deb
    installieren. Falls noch nicht alle benötigten Pakete installiert sind, einfach
    > apt-get -f install
    starten.


    Hier habe ich mal eine Frage ob die Installation im Raspberry- Wheezy im Terminal erfolgt oder mit "Win32DisImager" und der SD-Karte mit Installiert wird?


    Sorry neu-user in Linux :lol::bahnhof::blush2:


    Grüße Manfred

    :gewitter:


    TOA-Blitzortung:
    Station Gönningen (RED) DL2GKM 337/774 & 435/775-> Controller PCB RED 10 Ver.3 (b) und Amplifier PCB 12 Ver.3 (b)
    Station Gönningen (GREEN) 435-> Controller PCB 6.8usb und Amplifier PCB 5.7


    Wetterstation:
    Ultimeter 2100 Peet Bros gekoppelt mit APRS Netzwerk.

  • Vielen Dank für das Paket, da ich Neuling auf dem Raspberry bin und es nun eigentlich ohne groben Probleme geschafft habe alles zum Laufen zu bringen, wäre da noch eine Frage offen bezüglich der GPS Baudrate.


    comm baud auf 19200 (per nano zu ändern)
    gps baud 4800 (via jumper am board auf 38400? oder passt so?)


    Liebe Grüße

  • Hallo in die Runde,


    nachdem mein Raspberry Pi bzw. die SD-Karte drei Jahre ohne Probleme gearbeitet haben musste ich nun die Karte austauschen.
    Ich habe die aktuelle NOOBS-Version installiert und die Anleitung von Andreas (siehe oben) befolgt.
    Aber irgendwie geht der Tracker jetzt nicht mehr, die Station wird immer noch als offline gezeigt.


    In der Logdatei findet sich folgendes:
    03.06.2016 16:46:25.553 NOTICE : startup /usr/bin/bo-tracker -g sirf -b 115200 -d /dev/ttyUSB0 -h rechenserver.de -u (Username) -p (Passwort) --logfile=/var/log/blitzortung-tracker.log
    03.06.2016 16:46:34.597 WARN hardware.Pcb : invalid data 'L,28EB08,9F779D79937A887E7D827783738473857385768279817C817E80807E817F8180807F7F7F7E817C827C817C817A837784758373847187718675837A838081$
    03.06.2016 16:46:34.636 NOTICE hardware.gps.data.Time : getTime() no time available
    03.06.2016 16:46:34.637 WARN hardware.parsing.Samples : Samples() invalid event time
    03.06.2016 16:46:34.638 WARN hardware.parsing.Samples : Samples() could not parse 'L 36D943 80588062806D80758082809180988199819A8198818D81838187818F81938190828D828D828C8289828582828280837E827$
    03.06.2016 16:46:34.639 WARN hardware.Pcb : invalid data 'L,36D943,80588062806D80758082809180988199819A8198818D81838187818F81938190828D828D828C8289828582828280837E827D817A81778078807A


    Der Status sieht gut aus:
    hardware
    firmware: 31e
    comm
    baudRate: 115200
    interfaceName: /dev/ttyUSB0
    gps
    status: A
    baudRate: 4800
    longitudeError: 4e-06
    altitude: 188
    altitudeError: 0
    longitude: 10.700353
    latitudeError: 3e-06
    date: 2016-06-03
    satelliteCount: 6
    time: 17:03:57
    latitude: 51.297861
    type: SiRF
    tickError: 0.0
    ticksPerSecond: 2500096.62
    process
    numberOfEvents: 357
    uptime: 00:17:24
    eventsPerSecond: 0.34261
    numberOfSeconds: 1042
    command: getInfo
    software
    version: debT 1.0.7



    Was bedeuten die Logeinträge?



    Danke, Gruß
    Max

  • Hallo Max,


    ich kenne die Lösung mit Raspberry nicht.
    Was mir auffällt sind die unterschiedlichen Baudraten von Kommunikation und GPS.


    Wenn ich ein Problem mit meinem Tracker hatte, habe ich zuerst mit kleinen Baudraten angefangen und wenn das lief, habe ich danach erhöht (immer mit Initialisierung des GPS). Vielleicht geht das bei Dir auch.

    Man liest sich ...
    Olivier
    _________________________________________
    boost-project: EInkaufen und Gutes dabei tun - ohne Mehrkosten.

  • Hallo Max,


    ich kenne die Lösung mit Raspberry nicht.
    Was mir auffällt sind die unterschiedlichen Baudraten von Kommunikation und GPS.

    Die unterschiedlichen Baudraten haben schon ihre Richtigkeit. 115000 Baud ist Computerinterface und die 4800 Baud ist das GPS. Jenachdem was du für eine Antennenchip hast solltest die Baudrate korrigieren. 115000 Baud ist die vom RED System mit Mediatek Chip
    Was die anderen Meldungen betrifft, solltest dich an Egon oder Tobias wenden.
    03.06.2016 16:46:34.597 WARN hardware.Pcb : invalid data
    Das deutet auf einen gravierenden Fehler bei dir hin. Siehe Hinweis weiter oben Baudrate.(Vermutung)

  • Hallo zusammen,


    der Tracker auf meinem Raspberry funktioniert irgendwie jetzt gar nicht mehr.
    Schließe ich es (System Green) an einen Windows-PC, funktioniert es sofort.
    Eine Neuinstallation von Jessie brachte keine Abhilfe.


    Lasse ich mir den Stream von /dev/ttyUSB0 mit miniterm ausgeben, sieht alles gut aus:
    $S,F7993D,A,203452,100817,5xxx.8813,N,0xxx.0175,E,182.8,06,31e*4C
    $L,DCF771,715D71607568796E7D7A828787918C9A91A694AD93A98F9D889082817F777F78807F8386858B858E8590858D858B848E8590869087928793868F858B83888186818282808180818083808384838783....
    usw.


    Abfrage mit bo-tracker-status gibt nur "no connection".


    Hat jemand einen Tipp, was ich noch machen könnte?


    Danke, Gruß
    Max