Hilfe bei WDLive mit WSWIN und WS3600

  • Hallo Leute,


    ich habe mir heute mal die Demoversion von WDLive heruntergeladen, um dass mal mit meiner WS 3600 + WSWIN zu testen.


    Habe mir schon die entsprechenden Dateien aus dem Downloadbereich gezogen, doch ich habe keine Ahnung, wie ich die wo einsetze, so dass WDLive meine Daten anzeigt!


    Hat jemand zufällig ein kleines Tutorial für mich? (mit WSWIN-Einsatz)


    Danke


    Gruß


    Christian ;)

  • Das ist nicht so schwierig:


    Du hast die drei Dateien
    Wswin_nrt.txt ws_clientrawdaily.txt ws_clientrawextra.txt aus der Winzip-Datei ins WSWin-Verzeichnis extrahiert.
    Diese 3 Dateien öffnen und dort oben den Pfad entragen wo sich dann die Dateien erstellt werden.


    Nun folgt der nächste Schritt:


    In WSWin, klickst du dann unter "Steuerung"- "Near Real Time" aus, und wählst die Einstellung "WSWin_nrt.txt" aus.


    Die Installation von WDLive sollte in ein Verzeichnis angelegt werden, z.B: WSWin/WeatherDisplayLive/.


    Als nächstes kannst du dann in deiner Webseite folgenden Code einbauen: Siehe Anlage:


    Die Datei "wdlconfig.xml" mit einem Text-Editor öffnen:
    Siehe Anlage: (Daten in Klammern stehen, abändern)


    Weitere Hilfe zu der wdlconfig.xml - Datei, ist in der PDF-Datei zu finden.


    Die 3 Dateinen die WSWin erstellt, kannst du z.B: mit dem Programm FTP-Watchdoc auf den Server senden:


  • Hi Manfred,


    danke für das kleine Tutorial!


    Jetzt funktioniert es :tongue:


    Wenn ich WDLive kaufen möchte, muss ich dann zwingend WD haben?


    Hier ein Ausschnitt von


    Zitat

    Weather Display Live kostet lediglich 26 EUR inkl. 19% MwSt (Weather-Display-Vollversionslizenz aber vorrausgesetzt)!


    Da steht, dass ich das haben muss :( Ich habe aber keine Lust WD noch dazuzukaufen :evil:


    Gruß


    Christian


    PS: Werden die clientrawdaily.txt und die clientrawextra.txt jeden Tag neu erstellt? Weil ich sonst diese Standartdaten, wie sie schon mitgeliefert wurden, angezeigt bekomme (mit UV usw--> Einen UV-Sensor habe ich nämlich garnciht)! Oder kann ich die schon vorhandenen HeavyWeather bzw WSWIN-Daten umwandeln, sodass WDLIVE die unter "REKORDE" usw führt?

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von C0ldC0re ()

  • So dass freut mich, dass es funktioniert. ;)
    Wenn du die Vollversion bestellen möchtest, brauchst du hier nicht noch extra das Programm WD kaufen. Der Betreiber der Seite wuste nicht dass dies auch mit WSWin geht. Ich habe es genau so gemacht, habe hier nur 26 € per Überweisung bestellt. Die clientrawdaily.txt und clientrawextra.txt werden sowieso automatisch erstellt, wenn du das NTR-Flash aktiviert hast.

  • Nabend Manfred,


    Zitat

    Die clientrawdaily.txt und clientrawextra.txt werden sowieso automatisch erstellt, wenn du das NTR-Flash aktiviert hast.


    NRT-Flash habe ich aktiviert! (Du meinst doch die wswin_nrt.txt oder? )


    Ähm bis jetzt wurden die beiden Dateien noch nicht erstellt, kann aber sein, dass er das erst nach 24h Aufzeichnung macht, heisst ja auch clientrawDAILY->täglich ;)


    Jetzt noch eine kleine Frage:


    Kennst du dich mit Heavyweather aus? HW erstellt sich ja eine Datei -history.dat- worin er alle Wetterdaten speichert. Gibt es eine FUnktion, die mir jeden Monat eien neue history.dat erzeugt? Sonst wird das nämlich nen bisschen unübersichtlich alles in einer Datei zu haben (bis jetzt sind es nach 4 Wöchiger Aufzeichnung nämlich schon über 17000 Einträge 8o)!


    Achso hier hast du schonmal nen Testlink zu meiner Wetterpage:


    (WDLive ist unter Livewetter zu finden->bis jetzt noch eval-Version :] )


    Gruß


    Christian

  • Genau, die wswin_nrt.txt muss akiviert sein. Wenn hier nur eine Datei erzeugt wird, dann stimmt irgend was nicht, mit den Vorlagen zu WDLive. Sende mal meine Dateien als Anlage, muss blos noch der Pfad oben geändert werden:


    Auf der Seite die du als Link angegeben hast, finde ich die Testversion nicht.


    Mit Heavyweather, kenne ich mich leider nicht aus, kann dir leider nicht weiterhelfen.

  • Hi Manfred,


    Zitat

    Auf der Seite die du als Link angegeben hast, finde ich die Testversion nicht.


    :evil: Ich grade auch nicht! Das ist bei mir sowieso komisch, immer wenn ich neue Links im Menü hinzufüge, verschwinden die nach ner Zeit einfach so wieder.


    Ich werde es sofort korrigieren...


    Hier die Dateianhänge:

  • Also ich habe es mal getestet. WSWin legt nur eine Datei im Verzeichnis C:\Programme\WSWin\Html\WDLive ab.


    Lege doch den Ordner unter C:\WDLive an.
    Die Dateien die du runtergeladen hast, haben irgendwo einen Fehler drin. Wenn du meine Vorlage abänderst, und diese Verwendest, dann hast du alle 3 Dateien gleichzeitig.


    Also gebe als Pfad in allen 3 Dateien an: c:\WDLive\

  • Hi Manfred,


    hast du, als du die Dateien heruntergeladen hast, noch etwas daran verändert außer der Pfade?


    Weil ich in den folgenden Dateien weniger stehen habe als in deinen :( :


    Wswin_nrt.txt
    (Zum Beispiel fehlt hier eine komplette Zeile: %openfile&remove=ws_clientrawdaily.txt%%curminmaxhour_on% )


    ws_clientrawdaily.txt


    (in dieser Datei fehlen auch noch nen paar Sachen glaube ich)


    Dann teste ich das gleich nämlich mal mit deinen Dateien!


    Gruß


    Christian

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von C0ldC0re ()

  • Hi Manfred,


    also die Dateien werden jetzt erstellt!


    Doch wenn ich nun REKORDE aufrufe, steht bei mir bei manchen Daten ein roter Punkt vor dem Eintrag. (Daten zu alt??? Obwohl da das aktuelle Datum dran steht?)


    Wenn ich GRAPH aufrufe, werden bei mir in manchen 24h Ansichten (luftfeuchtigkeit oder Temperatur zum Beispiel) keine Daten angezeigt!


    Aber im 31 Tagerückblick stehen wieder alle Werte???? :(


    Danke trotzdem schonmal für deine Hilfe!


    Gruß


    Christian


    PS: Vorher standen viel mehr Werte unter REKORDE und jetzt sind es um einiges weniger Werte! Hast du das verändert? Ich lese mir mal die Anleitung zu WDL durch und gucke, wie ich die da wieder hinbekomme :P

  • Zur history.dat


    Ich habe nur eine pro Jahr zu laufen, aber macht bei mir (kein WDL) mit
    etwa 75.000 Datensätzen keine Probleme.
    Eine neue history.dat geht nur von Hand, nicht automatisch.

    Grüße aus dem Süden von Dessau (Stadt Dessau-Roßlau)
    Dirk



    ..... nicht "meckern und motzen", sondern "machen und klotzen" .....

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Sprite01 ()


  • Also der Rote Punkt in dieser SWF-Version (glaube 4.xxx) ist normal. Ich habe die neue Version drauf 5.03 !


    Unter Graph werden in der Testversion nicht alle Daten angezeigt, erst in der Vollversion.
    Die Temperatur innerhalb der letzten 24 Stunden werden in der Grafik angezeigt (nur Vollversion).
    Wie ich schon gesehen habe, kann WSWin hier einige Daten nicht korrekt umsetzen, aber dies ist nicht so schlimm.


    Es fehlen hier: 24 Stunden Luftfeuchte, 24 Stunden Niederschlag, und 24 Stunden Windrichtung.


    In den 31 Tage Rückblick werden die Werte eigentlich richtig angezeigt.


    PS: Eigentlich habe ich nur ein paar Variablen hier von den Vorlagen aus der Seite von Werner Krenn (PC-Wetterstation) eingefügt, die dort gefehlt haben.
    Mein Tipp dass die Daten immer aktuell sind: klicke mit der rechten Maustaste bei WSWin unter der Aufzeichnung, auf die Jahres, Monats und Wochenansicht an.

  • Hallo ihr zwei,


    danke für eure Beiträge!


    Jetzt habe ich ein anderes Problem:


    Ich habe Freitag Nacht um 0 Uhr meinen Rechner(=WetterPC) ausgeschaltet und habe ihn heute Mittag (Sonntag) wieder eingeschaltet. Habe mein HeavyWeather wieder angeschmissen, sodass er die letzten Werte, der vergangenden Stunden (Tag), auf meinem PC abspeichern konnte => kein Problem und alle Daten vorhanden. Danach habe ich natürlich WSWIN auch gestartet, sodass sich auch WSWIN alle aktuellen Daten von HeavyWeather holen kann=>Jetzt das Problem:


    Es fehlen bei WSWIN die Daten, aus der Nacht von Freitag auf Samstag, von 0 Uhr bis 9 Uhr morgens (ungefähr)!! Obwohl HeavyWeather alle Daten hat. :(


    **EDIT**


    Und noch eine Frage: Warum "löscht", WSWIn mir immer 1 von 2 selbsterstellten Links im Menü der HTML Seite??? "Instrumente" (auch selbst hinzugefügt) bleibt auch nach Neustart von WSWIN nur "LIVEwetter" löscht sich immer wieder 8o


    **


    Könnt ihr mir weiterhelfen?


    Danke schon jetzt und einen schönen Sonntag noch...


    Gruß Christian :D

    Dateien

    • komisch.jpg

      (218,8 kB, 144 Mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von C0ldC0re ()

  • Ich bin nun nicht der Experte, aber mein Ansatz zu den fehlenden Daten:


    Exportiere doch mal deine Monatsdatei aus WsWin und kontrolliere ob
    sich nicht ein falscher Datumswert/Zeitwert eingeschlichen hat.

    Grüße aus dem Süden von Dessau (Stadt Dessau-Roßlau)
    Dirk



    ..... nicht "meckern und motzen", sondern "machen und klotzen" .....

  • **********EDIT**********


    Sry Dirk, habe mich verguckt! Die Daten sind auch im Heavy Weather nicht mehr drin! ;(


    Entweder kurzzeitiger Ausfall weswegn auch immer....Batterie kann es ja nciht sein, da die Station ja jetzt auch noch funktioniert!


    Ich denke mir eher, dass die Station einfach "alte" Daten überschrieben hat, weil der interne Speicher voll war! Das ist die einzige Möglichkeit oder? (Ok Funkübertragung kann auch unterbrochen gewesen sein, aber 9 h?????)


    Aber kann der Speicher schon nach eineinhalb Tagen ohne "Download" der Daten auf den PC voll sein?


    ************************


    Danke trotzdem vielmals... :)


    Christian

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von C0ldC0re ()

  • Hi Dirk,


    hast wohl gerade die Editierung meines Beitrages nicht mitbekommen :P
    Guck ihn dir nochmal an, ist ja kein Problem!


    Bleibt nur noch diese Frage stehen:

    Zitat

    Warum "löscht", WSWIn mir immer 1 von 2 selbsterstellten Links im Menü der HTML Seite??? "Instrumente" (auch selbst hinzugefügt) bleibt auch nach Neustart von WSWIN nur "LIVEwetter" löscht sich immer wieder 8o


    :]


    Gruß


    Christian

  • Nein, habe ich nicht.
    Der Speicher der WS3600 kann aber nicht voll sein,
    ohne jetzt zu wissen was du für einen Intervall eingestellt hast.
    Die WS 3600 speichert 1750 komplette Datensätze.
    Bei meinem 5-Min-Intervall müssten das rund 30 Tage sein.

    Grüße aus dem Süden von Dessau (Stadt Dessau-Roßlau)
    Dirk



    ..... nicht "meckern und motzen", sondern "machen und klotzen" .....

  • Hi Dirk,


    ähm ne bei 30 Tagen (á 5min Intervall) wären das rund 8640 Einträge :P


    Ich glaube mein Intervall liegt bei 1-2 Minuten! Wo kann man den eigentlich einstellen? Kann Heavyweather diesen Wert einstellen? Der "Auzeichnungsintervall"- Wert in HW steht im Moment auf 1min :D Kann man damit auch den "echten Ablesewert" der Daten einstellen? ( Also wann die Station die Werte der Messinstrumente abnimmt)


    WSWIN kann ich nämlich auch auf 30 sec oder so stellen, obwohl der eigentliche Wert sich nur jede Minute ändert, weil er ja nur 1x in der Minute von den Messinstrumenten "abgenommen" wird!


    Gruß


    Christian


    PS: Für das Webseitenproblem haste noch keine Lösung oder?

  • :schock: Falsch gerechnet.
    Meines Wissens stellst du den Ausleseintervall nur mit HW ein.
    WsWin spielt da erst mal keine Rolle, da es ja nur die Überwachung der history.dat ist.
    Und da, wo bei dir jetzt eine Minute steht, da stellst du halt auf 5 min. ein.
    Ich nehme einen kürzeren Intervall nur bei "Kyrill" oder ähnliches.


    Für dein Webseiten-Problem habe ich keine Lösung im Moment.
    Das Menü erzeugt ja WsWin selbstständig. Da mußt du evtl. den Haken bei "automatisch Start.html erzeugen" o. ä. entfernen.

    Grüße aus dem Süden von Dessau (Stadt Dessau-Roßlau)
    Dirk



    ..... nicht "meckern und motzen", sondern "machen und klotzen" .....